Commits


remove unused got_object_idset_remove_random()


rename zbuf to inflate


undo previous; too much mixup in one data structure


store recently accessed objects at front of cache lists


speed up got_object_idset_remove_random() by almost 50%


fix got_object_idset_remove_random() for single-element set


init output param in got_object_idset_remove()


make data output param of got_object_idset_remove_random() optional


allow got_object_idset_remove() to retreive data pointer


fix leak in got_object_idset_remove()


introduce got_object_idset_remove_random()


undo previous; this approach won't work


allow removing an unspecified element with got_object_idset_remove()


store commit timestamps as 'struct tm' in UTC


use signed int for max numer of object idset elements