Commits


rename zbuf to inflate


add an object id cache which backs the object cache


undo previous; too much mixup in one data structure


store recently accessed objects at front of cache lists


add some disabled refcount debug code


size object caches independently of each other


add a commit cache as well


no need to manually count elements of a set


add a tree object cache to struct got_repository


introduce struct got_object_cache


implement repository object cache via object_idset


remove debug output


add a very simple object cache


try to infer repository path from work tree


rename 'refs' to 'reference'