Commits


rename got_error_prefix_errno() to got_error_from_errno()


lock branch reference file during 'got commit' to prevent a race


open the file index just once when adding multiple files


got_error_from_errno -> got_error_prefix_errno also add got_error_prefix_errno2 and got_error_prefix_errno3 which should hopefully all be merged into a single function with variadic args (but can't alloc mem)


make got path APIs available to library consumers


omit unused mode argument to open(2)


fix bugs in got_repo_map_path() and add more related tests


read UUID back from work tree meta data


more specific mmap(2) failure checks


check for errors from close(2)


stop checking for a worktree in open_repo()


add read support for packed refs


happy new copyright year


make got_repo_get_path_git_dir() return const char *


make got_repo_get_path() return const char *