Commits


rename got_error_prefix_errno() to got_error_from_errno()


disallow directories with 'got add'; add a TODO item for them


while (1) -> for (;;)


got_error_from_errno -> got_error_prefix_errno also add got_error_prefix_errno2 and got_error_prefix_errno3 which should hopefully all be merged into a single function with variadic args (but can't alloc mem)


make got path APIs available to library consumers


init output parameter in walk_dir()


plug memory leaks in diff_fileindex_dir()


add support for partial updates, which affect specific paths only


test and improve behaviour for wt edit vs repo rm conflict


add a basic implementation of 'got rm'


implement a basic 'got add' command


allow file index entries without blobs and/or commits


make file index flags private to fileindex.c


renmae GOT_FILEIDX_F_NOT_ON_DISK to GOT_FILEIDX_F_NOT_FLUSHED


add missing 'static' for local functions