Commits


rename sha1.c to hash.c


include sha2.h where sha1.h was included


sed -i s/sha1/hash not exactly, some "hash" were changed back to "sha1" for the time being.


got_imsg_fetch_ref: use struct instead of buffer for id ok stsp@


got_imsg_fetch_have_ref: use struct instead of buffer for id ok stsp@


replace malloc+memcpy with strndup. no functional change intended ok stsp@


got: minor refactor of got_pathlist_free() API Accept flag parameter to optionally specify which pointers to free. This saves callers looping through the list to free pointers. ok + fix stsp@


fix uninitialised fildes variables in libexec helpers Reviewed and uncovered as part of the diff in the forthcoming commit (pathlist API refactor). ok stsp@


always cast ctype' is*() arguments to unsigned char ok stsp@


make 'got clone -b' work for repositories which lack a HEAD reference ok op@


avoid looping over SHA1Update() in got-fetch-pack; suggested by millert@


got-fetch-pack: fix wrong memmove length leading to dubious checksum failures ok millert tracey


remove trailing whitespace; patch by Josiah Frentsos


fix snprintf error handling follow the "proper secure idiom" described in the CAVEATS section of printf(3). reminded by tb@ and millert@


convert two snprintf to strlcpy "looks good to me" millert@