Commits


represent packfile hash as byte array in the privsep layer, not as object ID


rename an argument of got_privsep_send_index_pack_req() for clarity


move functions from privsep.c to the helpers which use them where possible


add support for fetching arbitrary references to 'got clone' and 'got fetch'


remove GOT_FETCH_DEBUG and toggle fetch debug output with -v option instead


add support for listing remote branches and tags to 'got clone' and 'got fetch'


add support for fetching specific branches to 'got clone' and 'got fetch'


fix allocation size in got_privsep_recv_gitconfig_remotes(); found by free(3)


transmit the 'mirror' flag correctly in got_privsep_send_gitconfig_remotes()


fetch only HEAD branch and tags by default; add -a option to fetch everything


fix wrong sizeof in got_privsep_send_fetch_req()


add support for repository mirrors to 'got clone' and 'got fetch'


fix typos in error messages


implement 'got fetch'


initialize pack file size output paramter of got_privsep_recv_fetch_progress()