Commits


get rid of an inline implementation of got_object_qid_free()


avoid dependency on delta.o in binaries which don't need it


disambiguate abbreviated object IDs based on object type


rename got_error_prefix_errno() to got_error_from_errno()


while (1) -> for (;;)


got_error_from_errno -> got_error_prefix_errno also add got_error_prefix_errno2 and got_error_prefix_errno3 which should hopefully all be merged into a single function with variadic args (but can't alloc mem)


make got path APIs available to library consumers


more progress on generating new tree entries


make parse_tree_entry() require a mode field


bump copyright year in object_parse.c


fix more unbound string searches in object_parse.c


remove unused variable in got_object_parse_header()


don't use unbound strlen() while parsing objects


rename got_zstream_* to got_inflate_*


move declaration of object labels to got_lib_object.h