Commits


parse_ref_line: parse sha256 hashes


bump got_object_id hash size to make room for sha256 digests


rename sha1.c to hash.c


provide functions to parse/serialize sha256 digests


include sha2.h where sha1.h was included


handle objectformat=sha256 repository format must be at least 1 for object format to be available.


sed -i s/sha1/hash not exactly, some "hash" were changed back to "sha1" for the time being.


add hash enum and s/sha1/hash in got_object_id


introduce got_error_checksum ok stsp@


introduce got_object_id_hex to replace some got_sha1_digest_to_str() It's an analogous to got_object_id_str but writes to the given buffer. ok + improvements by stsp@


rename a function for clarity


add a TODO item regarding missing client-side pack content verification


typo and style(9): do not use function calls in initialisers. ok stsp@


fix mistaken instances returning NULL instead of err While here, for consistency, check dup() return value for -1 rather than < 0. ok stsp@


fix missed doc update of new 'got fetch' behaviour ok stsp@