Commits


rename got_zstream_* to got_inflate_*


move declaration of object labels to got_lib_object.h


rename "object tags" to "labels" to avoid confusion with tag objects


use path lists to sort dirent, tree object, and file index entries


Support tags in Linux git repo which do not carry name of tagger.


wrap another long line


there's no point in embedding the object header in commits


eliminate got_object_open() round-trip when opening commits


remove struct got_object from public library API


make commit objects opaque in the library's API


more support for tag objects; new code is not yet reachable


Set output to NULL if got_object_parse_tree() fails.


remove unused declarations


unnecessary repeated strlen() in parse_tree_entry()


remove object_idcache; use object_idset instead