Commits


rename got_parent_id to got_object_qid; better generic name


move got_opentmp* functions to public API; used from tog


read object headers with privsep


rename 'refs' to 'reference'


verify diff output in blob diff test


remove GOT_ERR_NO_MEM, we can just use errno in those cases


fix memleak in test helper function print_tree_object()


use pledge(2) in regression tests


use stricter CPPFLAGS from mpi


fix repos path argument processing in repository_test


move got_sha1.h to private lib directory


public API is now independent of sha1.h and zlib.h


make length of id string an implementation detail


remove got_parse_object_id(), add got_object_open_by_id_str() instead


make struct got_object_id opaque