Commits


regress: change naming scheme for certs, add GENCERT_FLAGS knob Call the certificates .pem and the keys .key; use contrib/gencert to generate the certificates and provide a GENCERT_FLAGS knob so that regress can be run with EC keys (GENCERT_FLAGS=-e). Still no automatic way of testing with both RSA and EC keys.


bundle libtls gmid (like all other daemons that want to do privsep crypto) has a very close relationship with libtls and need to stay in sync with it. OpenBSD' libtls was recently changed to use OpenSSL' EC_KEY_METHOD instead of the older ECDSA_METHOD, on the gmid side we have to do the same otherwise failures happens at runtime. In a similar manner, privsep crypto is silently broken in the current libretls (next version should fix it.) The proper solution would be to complete the signer APIs so that applications don't need to dive into the library' internals, but that's a mid-term goal, for the immediate bundling the 'little' libtls is the lesser evil. The configure script has gained a new (undocumented for the time being) flag `--with-libtls=bundled|system' to control which libtls to use. It defaults to `bundled' except for OpenBSD where it uses the `system' one. Note that OpenBSD versions before 7.3 (inclusive) ought to use --with-libtls=bundled too since they still do ECDSA_METHOD.


use REGRESS_HOST to specify the host to listen to; use in CI some CI envs don't like `listen on localhost' but tolerate INADDR_ANY or IN6ADDR_ANY_INIT.


rework the configure script now it resembles less oconfigure and more the configure scripts I'm using in my recent projects. I'd argue it's more easy to use it.


remove regress/sha we can use cmp to tell if two files are different, which also has the benefit of being available everywhere and reporting the byte offset of the first difference. Reduces the test dependencies on some systems.


ignore and clean fcgi.sock


rework `make dist'


refactor the makefile / configure steal more (good) stuff from mandoc-portable :)


check for the expected page in test_auto_index not just the number of lines, check the full page!


add tests for the type block


typo


retire the old gg


rename `runtime' to `regress' while there also kill an unused rule `regress', it's now redundant since all the tests are run together.


run all kinds of tests via tests.sh/runtime while there also change the dependency in the makefile: iri_test should be alone, not as deps of `data'.


allow to run only a subset of the runtime tests with make TESTS='test_1 test_2 ...' regress now it's possible to run only that specified subset of tests. It's really useful during debugging :)