Commits


rename got_error_prefix_errno() to got_error_from_errno()


got_error_from_errno -> got_error_prefix_errno also add got_error_prefix_errno2 and got_error_prefix_errno3 which should hopefully all be merged into a single function with variadic args (but can't alloc mem)


error: introduce got_error_prefix_errno for better errno messages


make got path APIs available to library consumers


redo: fix tree_entry_dup error path


revert previous


fix tree_entry_dup error path


more progress on generating new tree entries


expose a static helper function as got_object_get_path()


omit unused mode argument to open(2)


fix double-free in error path of open_blob()


add initial implementation of 'got revert'


avoid code duplication in error case of open_blob()


prevent double-close(2) of file descriptors passed in imsg


check for errors from close(2)