Commits


add conversion functions for fileindex/stat permission bits


keep fileindex->tree diff code similar to fileindex->DIR diff code


don't pass DIR pointers around needlessly in fileindex.c


fix 'got status' recursion problems


rename got_error_prefix_errno() to got_error_from_errno()


disallow directories with 'got add'; add a TODO item for them


while (1) -> for (;;)


got_error_from_errno -> got_error_prefix_errno also add got_error_prefix_errno2 and got_error_prefix_errno3 which should hopefully all be merged into a single function with variadic args (but can't alloc mem)


make got path APIs available to library consumers


init output parameter in walk_dir()


plug memory leaks in diff_fileindex_dir()


add support for partial updates, which affect specific paths only


test and improve behaviour for wt edit vs repo rm conflict


add a basic implementation of 'got rm'


implement a basic 'got add' command