Commits


label staged blobs with "(staged)" in got diff output


remove unused function got_diff_blob_file_lines_changed()


initial 'got stage -p' implementation


introduce got_diff_blob_file_lines_changed()


speed up rebase and histedit path prefix check: skip blob content diffs


introduce support for abbreviated object IDs


implement search for 'tog blame'


generalize got_diff_tree() by adding a diff output callback


use got_object_tree_find_entry() instead of local copy in diff.c


rename got_error_prefix_errno() to got_error_from_errno()


got_error_from_errno -> got_error_prefix_errno also add got_error_prefix_errno2 and got_error_prefix_errno3 which should hopefully all be merged into a single function with variadic args (but can't alloc mem)


make got path APIs available to library consumers


use correct diff header label for deletion in got_diff_blob_file()


add missing 'static' for local functions


check for errors from fclose()