Commits


switch back to searching packed objects first; it is indeed faster


open local objects before searching packs; faster on large repos


introduce support for abbreviated object IDs


make search actually work in 'tog blame'


implement search for 'tog blame'


test and fix 'got revert' with a path in a sub-directory Relax input path requirements of got_object_id_by_path() to make things easier to callers. Allows the revert code to pass a path from the file index in lieu of a repository path.


set_max_datasize() should be a static function


set datasize limit of got-read-pack helpers to maximum


rename got_error_prefix_errno() to got_error_from_errno()


got_error_from_errno -> got_error_prefix_errno also add got_error_prefix_errno2 and got_error_prefix_errno3 which should hopefully all be merged into a single function with variadic args (but can't alloc mem)


error: introduce got_error_prefix_errno for better errno messages


make got path APIs available to library consumers


redo: fix tree_entry_dup error path


revert previous


fix tree_entry_dup error path