Commits


include <limits.h> instead of <sys/limits.h>; patch by Thomas Klausner


rename got_error_prefix_errno() to got_error_from_errno()


while (1) -> for (;;)


got_error_from_errno -> got_error_prefix_errno also add got_error_prefix_errno2 and got_error_prefix_errno3 which should hopefully all be merged into a single function with variadic args (but can't alloc mem)


check for errors from close(2)


check for errors from fclose()


eliminate got_object_open() round-trip when opening tags


add got-read-tag libexec helper