Commits


rename got_error_prefix_errno() to got_error_from_errno()


got_error_from_errno -> got_error_prefix_errno also add got_error_prefix_errno2 and got_error_prefix_errno3 which should hopefully all be merged into a single function with variadic args (but can't alloc mem)


make got path APIs available to library consumers


inline open(2) flags in got_lockfile_lock()


fix allocation size bug in got_lockfile_lock()


fix bug in got_lockfile_lock() where it never succeeded


add a lockfile API