Commits


rename got_error_prefix_errno() to got_error_from_errno()


got_error_from_errno -> got_error_prefix_errno also add got_error_prefix_errno2 and got_error_prefix_errno3 which should hopefully all be merged into a single function with variadic args (but can't alloc mem)


happy new copyright year


remove unused definition of nitems()


avoid use-after-free via got_object_idset_for_each()


allow got_object_idset_for_each() to return an error


remove unnecessary #include


use userspace red-black tree macros, not kernel ones


remove object_idcache; use object_idset instead


implement object idset with a red-black tree


no need to zero new idset elements during allocation


reduce the amount of memcmp() calls via got_object_idset_add()


fix bug where duplicates were being added to object idset


remove unused got_object_idset_remove_random()


rename zbuf to inflate