Commits


remove redundant condition check in cmp_entries()


make cmp_entries() operate on paths instead of structs


move forward declaration of diff_fileindex_tree() further down


move definition of cmp_entries() closer to point of use


turns out in_same_subdir() check is mostly redundant


simplify in_same_subdir()


eliminate code duplication in cmp_entries() and in_same_subdir()


eliminate redundant strlen() call inside in_same_subdir()


eliminate redundant strlen() call in cmp_entries()


eliminate code duplication in cmp_entries()


invert same subdir check in cmp_entries(); no functional change


remove unused parameter of in_same_subdir()


happy new copyright year


fix bug where update got confused by sub-sub directories


fix more bugs in the update walk and add more tests