Commits
Commit:
24232204eb43c6b12bdf7dfad526276bd914fadf
Author:
Omar Polo <op@omarpolo.com>
Date:
Sat Sep 10 12:24:39 2022 UTC
update depends
Commit:
3eabd37fe7586fca2ca5f83411849ff7dd4cebd2
Author:
Omar Polo <op@omarpolo.com>
Date:
Thu Sep 8 21:18:04 2022 UTC
adjust install/uninstall target

gmid.1 was moved as gmid.8 and now we have `ge' too
Commit:
0126d91d1d80d7d8e794b2176556fce969f165cd
Author:
Omar Polo <op@omarpolo.com>
Date:
Wed Sep 7 20:47:33 2022 UTC
add ge: gemini export!
Commit:
d29a2ee2246e1b1b0c5222a823820e42422c894e
Author:
Omar Polo <op@omarpolo.com>
Date:
Tue Sep 6 16:11:09 2022 UTC
get rid of the CGI support

I really want to get rid of the `executor' process hack for CGI scripts
and its escalation to allow fastcgi and proxying to work on non-OpenBSD.

This drops the CGI support and the `executor' process entirely and is
the first step towards gmid 2.0. It also allows to have more secure
defaults.

On non-OpenBSD systems this means that the sandbox will be deactivated
as soon as fastcgi or proxying are used: you can't open sockets under
FreeBSD' capsicum(4) and I don't want to go thru the pain of making it
work under linux' seccomp/landlock. Patches are always welcome however.

For folks using CGI scripts (hey, I'm one of you!) not all hope is lost:
fcgiwrap or OpenBSD' slowcgi(8) are ways to run CGI scripts as they were
FastCGI applications.

fixes for the documentation and to the non-OpenBSD sandboxes will
follow.
Commit:
07fbbf06108419e7451fcc4f2270d287270a97cd
Author:
Anna “CyberTailor” <cyber@sysrq.in>
Date:
Thu Jul 7 08:38:49 2022 UTC
include contrib/ in dist
Commit:
b48eb0db52b88c5da0d0096c25dfd4ec823e3f4b
Author:
Omar Polo <op@omarpolo.com>
Date:
Mon Jul 4 15:04:46 2022 UTC
add missing manpage for gg
Commit:
5734723f92a0fd72967e89f9460ff9552ea9aff2
Author:
Omar Polo <op@omarpolo.com>
Date:
Mon Jul 4 14:09:52 2022 UTC
typo
Commit:
870063d34412314da347f65ff4bd22d84dcac4dc
Author:
Omar Polo <op@omarpolo.com>
Date:
Mon Jul 4 13:53:51 2022 UTC
include Makefile.depend too
Commit:
96e3c013146396d02318685d79ed7025a09ffb43
Author:
Omar Polo <op@omarpolo.com>
Date:
Mon Jul 4 13:44:38 2022 UTC
refactor the makefile / configure

steal more (good) stuff from mandoc-portable :)
Commit:
a3ebbccb8eda291462423682348e7031fb77a454
Author:
Omar Polo <op@omarpolo.com>
Date:
Mon Jul 4 09:52:44 2022 UTC
the install target ought to depend on gg too
Commit:
bf2850b938691a94e8926aa8952d043b620fdefb
Author:
Omar Polo <op@omarpolo.com>
Date:
Thu Apr 7 17:51:26 2022 UTC
install gmid.conf.5 too
Commit:
2a7f69f4eeb32a561a5a731e05145136030b4a71
Author:
Omar Polo <op@omarpolo.com>
Date:
Tue Mar 29 12:21:08 2022 UTC
fix `make static': compile `gg' too!
Commit:
57d2fca4b460c3c6aceb3f3aa6cc97ece9316022
Author:
Omar Polo <op@omarpolo.com>
Date:
Sat Mar 26 11:57:27 2022 UTC
add target `test' alias for `regress'
Commit:
e20755180f19eae16b5781e562978faf05f9579b
Author:
Anna “CyberTailor” <cyber@sysrq.in>
Date:
Thu Feb 3 10:13:44 2022 UTC
add gg to `make regress` dependencies
Commit:
135307cfb08ed0e3b3ecadc2fde0e13643c5265a
Author:
Omar Polo <op@omarpolo.com>
Date:
Sun Jan 30 13:35:45 2022 UTC
install gg too
Omar Polo