Commits


add some initial code for zlib compression


improve error checking around inflateInit()


rename got_zstream_* to got_inflate_*


move declaration of object labels to got_lib_object.h


avoid code duplication in error case of open_blob()


rename "object tags" to "labels" to avoid confusion with tag objects


whitespace formatting fixes in include/


actually add log.sh tests to 'make regress'


make 'tog log' resolve paths just like 'got log' does it


fix bugs in got_repo_map_path() and add more related tests


prevent free with bogus pointer in 'got log' error path


fix 'got log PATH' in a bare git repository; broken by previous


introduce got_worktree_resolve_path()


make 'got log PATH' work consistently from inside a work tree


add missing 'static' for local functions