Commits


yet another cosmetic change


reorganize tests


fix casts for variables


implement .tag for messages


evaluate function arguments only once


don't cast if not needed


don't free the string/symbol in the value


another aesthetic change to the regression test output


capture the output of the child process


clear the stack before running a test


explain how to run the tests


run the tests


add should-fail keyword


add a test with should-fail as statement


add should-fail as block statement