Commits


verify that length string read from packet contains hex digits only


improve strtol checking in got-fetch-pack


convert flushpkt to struct got_error


convert writepkt to struct got_error


convert readn and readpkt to struct got_error


knf


more reasonable minimum length check in check_pack_hash()


make check_pack_hash() return a struct got_error


add_symref modifies 'capa' so it cannot be const


pledge got-fetch-pack ("stdio recvfd")


use more readable names for items parsed from refline, and plug related leaks


remove got_has_object() for now; this would require imsg to main process


mark some functions static in got-fetch-pack


remove got_ prefix from static functions in got-fetch-pack


add missing \n in debug output