Commits


introduce got_object_id_hex to replace some got_sha1_digest_to_str() It's an analogous to got_object_id_str but writes to the given buffer. ok + improvements by stsp@


rename a function for clarity


add a TODO item regarding missing client-side pack content verification


typo and style(9): do not use function calls in initialisers. ok stsp@


fix mistaken instances returning NULL instead of err While here, for consistency, check dup() return value for -1 rather than < 0. ok stsp@


fix missed doc update of new 'got fetch' behaviour ok stsp@


delete unused code serializes an id to a local buffer before before returning. ok stsp


yet another gotwebd TODO writing everything down to avoid forgetting stuff...


one more TODO for gotwebd


add an arrow after "more" as per jamsek suggestion


gotwebd: fix briefs/tags navigation overlap Introduces a separate field for the "next" button (now called "More") and adjusted the CSS/HTML so it's used. Finally, drops the old code used to handle the pagination for the BRIEFS/COMMITS cases. Needs a small hack for the time being, setting the action to TAGS. This is due how qs->action is changed in gotweb.c while handling the request. ok jamsek


zap trailing whitespace


another memcmp -> got_object_id_cmp


use got_object_id_cmp instad of memcmp where possible in object_parse.c ok stsp@


typo in comment it serializes the struct got_imsg_tree_entry, not tree_object. grep aid.