Commits


convert readn and readpkt to struct got_error


knf


more reasonable minimum length check in check_pack_hash()


make check_pack_hash() return a struct got_error


add_symref modifies 'capa' so it cannot be const


pledge got-fetch-pack ("stdio recvfd")


use more readable names for items parsed from refline, and plug related leaks


remove got_has_object() for now; this would require imsg to main process


mark some functions static in got-fetch-pack


remove got_ prefix from static functions in got-fetch-pack


add missing \n in debug output


prepare for providing refs we already have in fetch request imsg currently we always send and expect an empty list


realloc(p, nmemb * size) -> reallocarray(p, nmemb, size)


add a TODO comment


re-enable fetching of offset deltas in got-fetch-pack