detect concurrent changes to the set of pack files while matching object IDs This should prevent a use-after-free crash I observed in gotwebd. ok op@

don't ignore err in got_privsep_recv_painted_commits

gotwebd: fix broken signal catching due to a pasto While here, remove completely the libevent handling of SIGPIPE in favour of the already existing signal(3) call to ignore it; there's no point in logging a SIGPIPE.

fix memory leak on error in got_privsep_recv_painted_commits() Diff from Kyle Ackerman, thank you! I've added a imsg_free() call before the break too.

remove 'bind interface removal' TODO item

gotwebd: inline and remove IMSG_SIZE_CHECK() I always find confusing if IMSG_SIZE_CHECK() takes pointers or not, and we had at least a few instances of wrong usages, so inline (with exact size checks) and remove the macro. ok stsp@

remove the gotwebd repository cache It only had 4 slots so was never quite useful, and sharing of sock->pack_fds across cached repositories seems problematic. with help from + ok op@

whitespace fix

gotwebd: ignore SIGPIPE in the sockets processes too

gotwebd: send a UNIQUE temp fd main_compose_sockets() has the 'feature' of implicitly dup(2)'ing the passed file descriptior. But it's not what we need for the temp fds, since those needs to be unique per-children. debugged with stsp@

gotwebd: don't chdir to / before spawning the child processes allows to run gotwebd from the got checkout again.

gotwebd: move log_init() even earlier. I can't read...

gotwebd: define constant instead of using the magic number 3 suggested by stsp@

gotwebd: make main_compose_sockets() close the fd on error concern raised by stsp@

gotwebd: get rid of proc.[ch] proc.c really shines when there's a network of different types of processes, potentially with a various number of instances each, that needs to exchange messages. Gotwebd instead has a much simpler design, and using proc.c causes more overhead (/headaches) than it solves. So, this attempts to provide the same functionalities but with a much simpler implementation that fits gotwebd better. ok stsp@